79185519305
05.06.2023 02:39

Написать программу с использованием классов на с++. дано натуральное число n (n< 10000). определить сколько цифр в числе, чему равна сумма его цифр, найти последнюю цифру числа. на си++, не на паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zuste
31.08.2020 22:37
#include <iostream>
#include <math.h>
using namespace std;

class NumHandler
{
int number;

public:
NumHandler(int n): number(n) {}

int getDigitCount()
{
int ret = 1, tested = 1, div;
while (true) {
div = (int) number / tested;
if (div == 0) {
return ret - 1;
}
else {
ret++;
tested *= 10;
}
}
}

int getDigitSum()
{
int ret = 0,
tenMult = pow(10, getDigitCount() - 1),
div;
while (tenMult >= 1) {
div = (int) number % (tenMult * 10) / tenMult;
ret += div;
tenMult /= 10;
}
return ret;
}

int getLastDigit()
{
return number % 10;
}
};

int main()
{
int num;
cout << "n = ";
cin >> num;
NumHandler handler(num);
cout << endl;
cout << "Число цифр: " << handler.getDigitCount() << endl;
cout << "Сумма цифр: " << handler.getDigitSum() << endl;
cout << "Последняя цифра: " << handler.getLastDigit() << endl;
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота