IxJugerNautxl
08.04.2021 14:12

Сортировка. метод выбора. напишите программу, которая сортирует массив и находит количество различных чисел в нем. пример: массив: 5 3 4 2 1 6 3 2 4 после сортировки: 1 2 2 3 3 4 4 5 6 различных чисел: 6 нужно . ,люди ,добрые

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
AlviaSil
03.08.2020 10:06
Begin
  var c, min, imin: integer;
  c := 0;
  var ar := readarrinteger('Массив:',readinteger());
  for var i := 1 to ar.Length do
  begin
    min := ar[c];
    imin := c;
    for var j := c to ar.Length - 1 do
    begin
      if(ar[j] < min) then
      begin
        min := ar[j];
        imin := j;
      end;
    end;
    swap(ar[c], ar[imin]);
    c := c + 1;
  end;
  write('После сортировки: ');
  ar.Println;
  write('Различных чисел: ',ar.Distinct.Count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота