dasha1957
14.08.2022 20:44

Уровень a. напишите программу, в которой сортировка выполняется «методом камня» – самый «тяжёлый» элемент опускается в конец массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nazhigp08m0u
05.10.2020 23:03
Var a:array[1..10000] of integer;
n,i,j,k,t:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
j:=n;
repeat
k:=j;
j:=0;
for i:=1 to k-1 do
if a[i+1]j:=i;
t:=a[i];
a[i]:=a[i+1];
a[i+1]:=t;
for t:=1 to n do
write(a[t],' ');
writeln;
end;
until j=0;
if k=n then
writeln(0); //Если перестановок не было, программа выводит только число 0. Если эта команда не нужна, можешь ее убрать
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота