AlexSashka2003
14.05.2023 15:09

Напишите программу в pascal abc для первых n двузначных натуральных чисел вывести суммы цифр каждого числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Var S,n,A:integer;
Begin
Write('n = ');ReadLn(n);
For n:= 10 to n+9 do
    Begin
    A:=n;
    S:=0;
    While A > 0 do
       Begin
       S:=S+A mod 10;
       A:= A div 10
       End;
    WriteLn('Сумма цифр ',n,' равна: ',S)
    End;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота