Suzdik23
23.08.2022 03:39

Напишите программу в pascal abc для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alexanders4234
05.10.2020 22:41
Var
   n,S,S3:integer;
Begin
Write('n = ');
ReadLn(n);
For n:= 1 to n do
    Begin
    S:=S+n;
    if n mod 3 = 0 then S3:=S3+n;
    End;
WriteLn('Сумма чисел [1..',n,'], кратных трём: ',S3);
WriteLn('Сумма всех чисел [1..',n,']: ',S);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота