sabovkristiурис
15.03.2021 04:53

Написать программу на языке си дано число х в 10 системе счисления. перевести его в систему счисления с основанием n

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Doktor77
05.10.2020 22:28
#include<iostream>
#include<string>
using namespace std;

int main()
{
    int x,n;
     string S;
     cout << "x = ",cin >> x;
     cout <<"n = ",cin >> n;
    while(x / n > 0){
        cout <<x / n<<" "<<x % n<<"\n";
        S = (char)(x % n<10?x % n+'0':x % n+'A'-10)+S;
        x = x / n;
        }
    if(x!=0){S = (char)(x<10?x+'0':x+'A'-10)+S;}
    cout <<"x_n = "<<S<<"\n";
     system("Pause");
     return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота