olchik75
20.05.2021 07:36

Составить программу pascal - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 1 введите два числа: 15 16 ответ: 15+16=31 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 3 введите два числа: 5 8 ответ: 5*8=40 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 0 пока!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tori0077
05.10.2020 22:09
Var A,B:real;
C:integer;
Begin
WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
ReadLn(C);
While C <> 0 do
   Begin
   Write('Введите два числа: ');
   ReadLn(A,B);
   Write('ответ: ');
   Case C of
   1:WriteLn(A+B);
   2:WriteLn(A-B);
   3:WriteLn(A*B);
   4:WriteLn(A/B);
   End;
   WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
   ReadLn(C);
   End;
WriteLn('Пока!');
End.

Вывод результат, точно как в условии:

Var A,B:real;
    C:integer;
Begin
WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
ReadLn(C);
While C <> 0 do
   Begin
   Write('Введите два числа: ');
   ReadLn(A,B);
   Write('ответ: ');
   Case C of
   1:
     if B < 0 then WriteLn(A,B,'=',A+B)
     else WriteLn(A,'+',B,'=',A+B);
   2:
     if B < 0 then WriteLn(A,'+',-B,'=',A-B)
     else WriteLn(A,B,'=',A-B);
   3:
     if B < 0 then WriteLn(A,'*(',B,')=',A*B)
     else WriteLn(A,'*',B,'=',A*B);
   4:
     if B < 0 then WriteLn(A,':(',B,')=',A/B)
     else WriteLn(A,':',B,'=',A/B);
   End;
   WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
   ReadLn(C);
   End;
WriteLn('Пока!');
End.

Пример:

1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход
4
Введите два числа: 4
-2.5
ответ: 4:(-2.5)=-1.6
1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход
1
Введите два числа: -3
-6
ответ: -3-6=-9
1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход
0
Пока!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота