NeZnayVsego
12.12.2022 11:48

Написать программу в pascalabc.net : найти все четырехзначные числа, сумма цифр1-го и 3-го разряда которых равна 6,а разность 2-го и 4-го равна -5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
egor570
09.09.2020 07:57
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  for var a:=1 to 6 do
    for var c:=0 to 5 do
      for var b:=0 to 4 do
        for var d:=5 to 9 do
          if (a+c=6) and (b-d=-5) then Write(a,b,c,d,' ');
  Writeln
end.

Результат
1055 1156 1257 1358 1459 2045 2146 2247 2348 2449 3035 3136 3237 3338 3439 4025 4126 4227 4328 4429 5015 5116 5217 5318 5419 6005 6106 6207 6308 6409
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота