vovachetaikin86
23.01.2022 10:57

Умоляю, ! напишите программу, которая в последовательности натуральных чисел определяет среднее арифметическое всех чисел, кратных 2 и оканчивающихся на 8. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: среднее арифметическое всех чисел, кратных 2 и оканчивающихся на 8.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lezifequliyeva
05.10.2020 21:18
Var
  s,n,k:integer;
begin
  Writeln('введите натуральные числа, 0 - окончание ввода');
  k:=0; s:=0;
  repeat
    Read(n);
    if n<>0 then
      if n mod 10 = 8 then begin k:=k+1; s:=s+n end
  until n=0;
  if k>0 then Writeln(s/k:0:4)
  else Writeln(0)
end.
 
Пример
введите натуральные числа, 0 - окончание ввода
34 17 8 32 1424 28 7 0
18.0000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота