dekok584p08crj
27.03.2021 03:39

Робот движется по клетчатому полю в соответствии с заданой программой. для записи программы используется следующая система команд:
1. u# - # раз сместиться на одну клетку вверх.
2.d# - # раз сместиться на одну клетку вниз
3.r# - # раз сместиться на одну клетку вправо
4.l# - # раз сместиться на одну клетку влево
5.#{} - повторить # раз последовательность команд в скобках
известно, что робот выполнил следующую программу:
10{u3 r3 u3 r3 d3 l3 d3 l6}

сколько клеток поля робот посетил ровно два раза? в ответе укажите целое число.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Qwerty20020505
06.05.2022 08:43

#include <iostream>

#include <cmath>

#include <algorithm>


int main()

{

size_t

 N, M;

std::cin >> N >> M;

int** arr = new int*[N];

for(int i = 0; i < N; i++)

 arr[i] = new int [M];

 

for(int i = 0; i < N; i++)

 for(int j = 0; j < M; j++)

  std::cin >> arr[i][j];

size_t max(abs(arr[0][0]));

for(int i = 0; i < N; i++)

 std::for_each(arr[i], arr[i]+M, [&max](auto& var)

 {

  if(abs(var) > max)

   max = abs(var);

 });

std::cout << "Максимальный элемент по модулю: " << max << std::endl;

for(int i = 0; i < N; i++)

 delete[] arr[i];

delete[] arr;

}


Задана матрица размером n×m. найти максимальный по модулю элемент матрицы
0,0(0 оценок)
Ответ:
Dan4ik1111111111
14.08.2022 03:19

s := 0; (начальное значение счётчика)

 for i := 1 to 9 do  (цикл по i)

if A[i - 1] < A[i] then begin (если текущий элемент больше предыдущего,

 s := s + 1; то увеличиваем счётчик на 1)

     t := A[i]; (меняем текущий элемент местами с предыдущим)

     A[i] := A[i - 1];

     A[i - 1] := t

   end;

Последние три строчки перед end - обычный алгоритм обмена значениями между двумя переменными (t = a; a = b; b = t).

Итак, моделируем, что делает программа и считаем число обменов.

0) 6 9 7 2 1 5 0 3 4 8 - исходный массив

1) 6 9 7 2 1 5 0 3 4 8 -> 9 6 7 2 1 5 0 3 4 8 ОБМЕН

2) 9 6 7 2 1 5 0 3 4 8 -> 9 7 6 2 1 5 0 3 4 8 ОБМЕН

3) 9 7 6 2 1 5 0 3 4 8 ОК

4) 9 7 6 2 1 5 0 3 4 8 ОК

5) 9 7 6 2 1 5 0 3 4 8 -> 9 7 6 2 5 1 0 3 4 8 ОБМЕН

6) 9 7 6 2 5 1 0 3 4 8 ОК

7, 8, 9) Ноль будет "всплывать" в конец, 3 ОБМЕНА

Всего будет 6 обменов, s = 6.

ответ: 6

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота