Rorshach
21.01.2021 10:00

Написать программу на языке c++ вам даётся 3 числа. требуется установить, возможно ли составить из них пифагоров треугольник. входные данные 3 целых числа, по модулю не превышающие 2 000 000 000. выходные данные если из чисел возможно составить пифагоров треугольник выведите "yes", иначе "no".

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
margaritakulak
05.10.2020 20:58
#include <iostream>
using namespace std;

int main() {
int a, b, c;
cout << "a, b, c: ";
cin >> a >> b >> c;
if ((a*a+b*b==c*c)||(a*a+c*c==b*b)||(b*b+c*c==a*a))
  cout << "YES";
else cout << "NO";
return 0;
}

Пример:
a, b, c: 1960509751 395427000 1999990249
YES
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота