logoschaolj
11.09.2021 22:41

17. напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
amira061
09.09.2020 07:33
Program n1;
var sum,a: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if(a=3) or (a=6) or (a=9) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота