irina567890
24.07.2020 15:58

Составить алгоритм и написать программу для вычисления факториала числа. факториал числа обозначается n! , произносится эн факториа́л) — произведение всех натуральных чисел от 1 до n включительно: n ! = 1 ⋅ 2 ⋅ . 0! =1. пример: 4! = 1*2*3*4 = 24. выполнить двумя цикл с предусловием и с фиксированым числом повторений). все переменные целочисленные.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Альба294
03.08.2020 08:53
Var n,f,i:integer;
begin
write('n = ');
readln(n);
f:=1;
for i:=2 to n do f:=f*i;
writeln(n,'! = ',f);
end.

Пример:
n = 6
6! = 720
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота