savech11
23.12.2022 09:27

Вопрос по информатике. написать программу на языке freepascal. дан массив определённой длины, в котором могут быть как положительные, так и отрицательные числа. проинициализировать массив и найти кол-во элементов массива до первого отрицательного и сумму элементов после него

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Bihan231
05.10.2020 20:47
Uses Crt;
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,k:integer;
   S:real;
Begin
Randomize;
ClrScr;
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ')
    End;
WriteLn;
i:=1;
k:=0;
While (A[i]>=0)and(i<N) do
   Begin
   k:=k+1;
   i:=i+1
   End;
if A[i]>=0 then k:=k+1;
WriteLn('k = ',k);
S:=0;
For i:= i+1 to N do
    S:=S+A[i];
WriteLn('S = ',S:0:3);
ReadLn
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота