Antoniow27
15.08.2021 09:37

Плз! на языке паскаля составьте программу, которая по введенному вами k – числу грибов, печатает фразу «мы нашли в лесу k грибов, причем согласовывает окончание слова «гриб» с числом k.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Adelka715
05.10.2020 20:47
Var
k:integer;
Begin
Write('k = ');ReadLn(k);
Write('Мы нашли ',k);
if (k>9)and(k<20) then WriteLn(' грибов')
else
   Case k mod 10 of
   0,5..9:WriteLn(' грибов');
   1:WriteLn(' гриб');
   2..4:WriteLn(' гриба');
   End;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота