Legend1111111
27.07.2021 02:18

3. только чётные! напишите программу, которая заполняет массив из n элементов целыми четными числами. гарантируется, что 0 < n ≤ 10000 . формат ввода входная строка содержит 2 числа n - количество элементов, а - начальное значение формат вывода программа должна вывести n элементов построенного массива, начиная с a, если а - четное и с а + 1, если а - нечетное, разделенных пробелами пример 1 ввод 5 4 вывод 4 6 8 10 12 пример 2 ввод 5 5 6 8 10 12 14

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gladiatorcor
05.10.2020 20:46
Var
A,N:integer;
M:array[1..10001] of integer;
Begin
ReadLn(N,A);
if A mod 2<>0 then A:=A+1;
For N:= 1 to N do
    Begin
    M[N]:=A;
    A:=A+2;
    Write(M[N],' ')
    End;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота