germanbet
16.06.2020 01:43

Народ, кто разбирается в pascal abs с этими : 1. написать программу, считающее среднее арифметическое цифр числа. 2. написать программу, считающее сумму цифр кратных "3" числа. 2а. написать программу, находящую минимальную цифру в числе. заранее !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Chehows
05.10.2020 20:32
Var
A,S,n:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
n:=0;
While A<>0 do
   Begin
   S:=S+A mod 10;
   n:=n+1;
   A:= A div 10
   End;
WriteLn('Sr = ',S/n);
End.

Var
A,S:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
While A<>0 do
   Begin
   if (A mod 10) mod 3 = 0 then S:=S+A mod 10;
   A:=A div 10
   End;
WriteLn('S = ',S);
End.

Var
A,m:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
m:=9;
While A<>0 do
   Begin
   if A mod 10 < m then m:= A mod 10;
   A:=A div 10
   End;
WriteLn('Min = ',m);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота