Aikaid
07.01.2020 14:19

Написать программу на паскале) сортировка пузырьком

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
leonleontiev6
05.10.2020 19:49
Const
   K = 13;
Var
   A:array[1..K] of integer;
   i,j:integer;
Begin
{Заполнение массива}
Write('Исходный массив: ');
For i:= 1 to K do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ')    
    End;
WriteLn;
{Сортировка пузырьком}
For i:= 1 to K do
    For j:= 1 to K-1 do
        if A[j]>A[j+1] then Swap(A[j],A[j+1]);
{Вывод массива}
Write('Отсортированный массив: ');
For i:= 1 to K do
    Write(A[i],' ')
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота