MuclePan
05.09.2022 12:51

:написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания. написать программу, получающую с клавиатуры целое число и выводящую его наоборот (например: вводим: 123, а выводит: 321).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
seba777
05.10.2020 19:20
Var
   A:longint;
   B:boolean;
Begin
B:=true;
Write('Введите целое число: ');ReadLn(A);
A:=Abs(A);
While A div 10 > 0 do
   Begin
   if A mod 10 < A div 10 mod 10 then B:=false;
   A:=A div 10
   End;
if B then Write('Верно')
else Write('Не верно')
End.

Var
   A:longint;
Begin
Write('Введите целое число: ');ReadLn(A);
if A < 0 then
   Begin
   Write('-');
   A:=-A;
   End;
While A > 0 do
   Begin
   Write(A mod 10);
   A:=A div 10
   End;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота