VikaPika561
10.08.2020 11:06

Написать программу, которая печатает введенное слово, начиная с последней буквы c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
AlexisA031117
05.10.2020 18:16
#include <iostream> 

void RevStr(char* S,int l)
{  
   char c;  
   if (l > 1)  
   {      
      c=S[0];      
      S[0]=S[l-1];      
      S[l-1]=c;      
      RevStr(S+1,l-2);    
   }
}  

int main(int argc, char* argv[])
{    
   char S[12]="Test of pen";       
   RevStr(S,11);    
   std::cout << S << std::endl;    
   return 0;
}
0,0(0 оценок)
Ответ:
milubel
05.10.2020 18:16
#include
#include
using namespace std;
string s;
int main ()
{
cin >> s;
reverse (s.begin(), s.end());
cout << s;
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота