rostikstorozhev
23.12.2021 18:34

1. составить программу ,которая определяет ,сколько раз в предложении встречается слово "дом". 2. составить программу ,вычисляющую длину самого короткого слова в предложении из трёх слов ,разделённых пробелами. паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
новичок535
05.10.2020 18:16
Код PascalABC.NET 3.2:

Var S:string;
i,k:integer;
Begin
Write('Введите строку: ');ReadLn(S);
LowerCase(S);
k:=0;
For i:= 1 to S.Length-2 do
    if S[i] = 'д' then
       if S[i+1] = 'о' then
          if S[i+2] = 'м' then
             k:=k+1;
WriteLn(k)
End.

Var
S:string;
i,d1,d2,d3:integer;
Begin
WriteLn('Введите строку:');
ReadLn(S);
i:=0;
Repeat
i+=1
Until S[i] = ' ';
d1:=i-1;
Repeat
i+=1
Until S[i] = ' ';
d2:=i-d1-2;
Repeat
i+=1
Until i = S.Length;
d3:=i-d2-d1-2;
if d3 < d1 then d1:=d3;
if d2 < d1 then d1:=d2;
WriteLn(d1)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота