Inna050798
18.11.2020 05:59

Циклы!

ниже записана программа. получив на вход число x , эта программа печатает два числа, l и m. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10.

var x, l, m: integer;

begin

readln(x);

l : = 0;

m : = 0;

while x > 0 do

begin

l : = l + 1;

if m < x then begin

m: =(x mod 10)*2;

end;

x : = x div 10;

writeln(l);

writeln(m);

end.

максимальное число у меня - 959.
но я не уверенна

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Использовать источники открытого огня (спички, зажигаприносить на уроки легковоспламеняющиеся вещества (лаки, краски, порох и т.п.); лки, петарды и др.); работать с электроприборами, имеющими повреждения корпуса или изоляции соединительных проводов; вставлять в отверстие приборов посторонние предметы; приносить и самовольно подключать какое-либо оборудование; производить самовольное переключение разъёмов оборудования; вставлять в отверстие приборов посторонние предметы; работать с электроприборами, имеющими повреждения корпуса или изоляции соединительных проводов;
0,0(0 оценок)
Ответ:
Юлиана95631
16.03.2020 11:58
Пусть *(n) - число звёздочек, которое выведет процедура f(n).

Так как f(n) всегда выводит 1 звёздочку, а если если n > 2 - то вызывает f(n - 1) и f(n - 2), то
*(n) = 1 при n <= 2
*(n) = 1 + *(n - 1) + *(n - 2) при n > 2.

*(1) = *(2) = 1
*(3) = 1 + *(2) + *(1) = 1 + 1 + 1 = 3
*(4) = 1 + *(3) + *(2) = 1 + 3 + 1 = 5
*(5) = 1 + 5 + 3 = 9
*(6) = 1 + 9 + 5 = 15
*(7) = 1 + 15 + 9 = 25
*(8) = 1 + 25 + 15 = 41
*(9) = 1 + 41 + 25 = 67
*(10) = 1 + 67 + 41 = 109
*(11) = 1 + 109 + 67 = 177
*(12) = 1 + 177 + 109 = 287
*(13) = 1 + 287 + 177 = 465
*(14) = 1 + 465 + 287 = 753
*(15) = 1 + 753 + 465 = 1219
*(16) = 1 + 1219 + 753 = 1973 >= 1500
ответ: 16.

Можно было заметить, что *(n) = 2F(n) - 1, где F(n) - число Фибоначчи, или просто выполнять программу для разных n.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота