savaam1
23.10.2022 07:41

Склавиатуры вводиться трёхзначное число ,составить программу которая проверит делиться ли она на сумму своих чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
шппмдд
05.10.2020 18:09
Var
A,B:integer;
Begin
WriteLn('Введите целое трёхзначное число');
ReadLn(A);
B:=(A div 100)+((A div 10) mod 10) + (A mod 10);
if (A mod B = 0) then Write(A,' делится на ',B)
else Write(A,' не делится на ',B);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота