DevA777
21.09.2020 15:16

Написать программу решения : вводить целые числа с клавиатуры, пока не будет введен ноль. а) найти сумму введенных чисел. b) найти количество четных отрицательных чисел среди введенных. c) найти максимальное число среди введенных.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
2285811
14.08.2020 19:53
//PascalABC.Net 3.2
begin
var max:=-1000000000;
var sum:=0; var count:=0; var a:=0;
repeat
a:=readinteger('Введите число: ');
if (a.IsEven) and (a<0) then inc(count);
if a>max then max:=a;
sum+=a;
until a=0;
writeln ('a) ', sum);
writeln ('b) ', count);
write  ('c) ', max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота