rotaru1930
06.03.2021 17:05

Массив из 10 элементов заполняется целыми числами. составьте программу, которая вычисляет среднее арифметическое элементов, заканчивающихся на цифру 7

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
TvoePolusladkoe
05.10.2020 18:04
Const
K = 10;
Var
A:array[1..K] of integer;
S,i,n:integer;
Begin
S:=0;
n:=0;
Write('Исходный массив: ');
For i:= 1 to K do
    Begin
    A[i]:=random(201)-100;
    Write(A[i],' ');
    if A[i] mod 10 = 7 then
       Begin
       S:=S+A[i];
       n:=n+1
       End;
    End;
WriteLn;
if n = 0 then WriteLn('В массиве нет элементов, оканчивающихся на семь')
else WriteLn('Среднее арифметическое элементов, оканчивающихся на семь: ',S/n);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота