Dashaass554
10.06.2022 13:46

Составить программу для вычисления значений переменной y при заданном значении n.(использовать три различных оператора цикла) y=

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
skutovakseniya2004
05.10.2020 18:00
Var
y:real;
n,i:integer;
Begin
Write('n = ');ReadLn(n);
{Цикл с параметром:}
y:=0;
For n:= 1 to n do
    y:=y+(1/n);
WriteLn('y = ',y);

{Цикл с постусловием:}
y:=0;
i:=1;
Repeat
y:=y+(1/i);
i:=i+1
Until i>n;
WriteLn('y = ',y);

{Цикс с предусловием:}
y:=0;
i:=1;
While i<=n do
   Begin
   y:=y+(1/i);
   i:=i+1
   End;
WriteLn('y = ',y)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота