1. определите, сколько элементов массива a равны заданному значению x. 2. вычислить произведение всех элементов массива a, которые делятся на 3. 3. определите в массиве a номер первого элемента, равного x.
Const K = 13; Var A:array[1..K] of integer; i,n,X:integer;
Begin Write('X = ');ReadLn(X); Write('Исходный массив: '); For i:= 1 to K do Begin A[i]:=random(21)-10; Write(A[i],' '); End;
n:=0; For i:= 1 to K do if A[i]=X then n:=n+1; WriteLn; WriteLn(n,' - кол-во элементов, равных ',X); End.
Const K = 13; Var A:array[1..K] of integer; i:integer; P:real;
Begin P:=1; Write('Исходный массив: '); For i:= 1 to K do Begin A[i]:=random(21)-10; Write(A[i],' '); if A[i] mod 3 = 0 then P:=P*A[i] End; WriteLn; WriteLn('Произведение элементов,кратных трём: ',P) End.
Const K = 13; Var A:array[1..K] of integer; i,X:integer; Begin Write('X = ');ReadLn(X); Write('А: '); For i:= 1 to K do Begin A[i]:=random(21)-10; Write(A[i],' '); End; WriteLn; i:=0; Repeat i:=i+1; Until (A[i]=X)or(i=K); if A[i]=X then WriteLn(i) else WriteLn('Таких элементов нет') End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку