Bobskromnaysh12
28.09.2022 20:51

Синформатикой, напишите программу на vb.net два натуральных числа называются дружественными, если каждое из них равно сумме всех делителей другого (само и другое число в качестве делителя не рассматривается). найти все пары дружественных чисел, которые меньше n (n вводится с клавиатуры) пример дружественных чисел: 220 и 284, т.к. сумма делителей 220 = 1+2+4+5+10+11+20+22+44+55+110=284 сумма делителей 284 = 1+2+4+71+142=220

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Zxbuffonfyjbsdj
05.10.2020 17:25
Код на VBScript - проверялся, работает

Function SumOfDividers(ByVal num)
    SumOfDividers = 0

    for i = 1 to num - 1
        if num mod i = 0 then SumOfDividers = SumOfDividers + i
    next
End Function

Sub Zadanie23317569(ByVal n)
    for i = 2 to n
        k = SumOfDividers(i)
        if SumOfDividers(k) = i then Msgbox i & " " & k
    next
End Sub

Zadanie23317569 300

Код на VB.Net  - исправление как догадалась, не проверялось

Sub Main(ByVal n)
    Dim i As Integer
    Dim k As Integer

    for i = 2 to n
        k = SumOfDividers(i)
        if SumOfDividers(k) = i then Console.WritelLine(i & " " & k)
    next
End Sub

Function SumOfDividers(ByVal num As Integer) As Integer
    Dim i As Integer
    SumOfDividers = 0

    for i = 1 to num - 1
        if num mod i = 0 then SumOfDividers = SumOfDividers + i
    next
End Function
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота