Kottenok2005
14.08.2020 16:39

Pascalabcnet. задайте массив из 10 элементов с датчика случайных двухзначных положительных чисел. a)определите количество четных элементов с четными индексами. выведите на экран исходный массив и полученное количество. б)найдите произведение элементов, кратных 5. выведите на экран исходный массив и полученное произведение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
iumpovavika85
09.08.2020 18:55
Var
A:array[1..10] of integer;
k:integer:=0;
Begin
For var i:= 1 to 10 do
    Begin
    A[i]:=random(10,99);
    Write(A[i],' ');
    if (i mod 2 = 0)and(A[i] mod 2 = 0) then k+=1;
    End;
WriteLn;
WriteLn('Количество четных элементов с четными индексами: ',k);
End.

Var
A:array[1..10] of integer;
P:real:=1;
Begin
For var i:= 1 to 10 do
    Begin
    A[i]:=random(10,99);
    Write(A[i],' ');
    if A[i] mod 5 = 0 then P*=A[i];
    End;
WriteLn;
WriteLn('Произведение элементов, кратных 5: ',P);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота