Войти
Регистрация
Спроси ai-bota
Милкович11
21.02.2021 14:34
Составьте программу,по которой вводится произвольное слово.выбрать число повторов.вывести число на экран лесенкой(со сдвигом вправо).без использования вложенного цикла.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
lyagaeva87
04.02.2021 10:23
Задание по оператору for. Напечатать свое имя, столько раз сколько тебе лет. ...
ilonadedyuhinaox7c9l
18.05.2023 06:12
ответьте на во Что такое управление спрайтами через обработчиков событий и нажатий клавиш? 2. Что нужно учитывать при программировании движения автомобиля влево, вправо,...
Anastasia16666
12.05.2020 04:30
Какое влияние проект Аналитической машины оказал на дальнейшее развитие вычислительной техники?...
lykuanenkoartem
09.12.2021 00:32
с проблемой на бесконечном поле имеется стена длины отрезков стены неизвестны. истина состоит из одного вертикального и 3 равных горизонтальных отрезков отрезки стены расположены...
Олеська11348
10.08.2020 22:56
Десятичное число 55 в некоторой системе счисления записано как 2001. Определи основание этой системы исчесления. ...
junejulytits
09.08.2022 11:15
Какие записи будут выбраны по условию отбора (Имя=,,Пётр,,)ИЛИ(Оклад 7000)?...
одиночка7
18.04.2021 15:49
55б! Паскаль. Задан массив, состоящий из 19 элементов целого типа. Найти сумму элементов, расположенных до первого отрицательного элемента. Если отрицательных элементов...
vladssos04
02.11.2022 01:56
с проблемой с проблемойна бесконечном поле имеется стена длины отрезков стены неизвестны. истина состоит из одного вертикального и 3 равных горизонтальных отрезков отрезки...
ALEXAND2033
15.11.2021 19:35
Какую формулу нужно прописать,чтобы найти лучший результат ...
Timyr1020
27.04.2023 23:42
Евро трак симулятор скачать на андроид...
Ответ:
соныч
05.10.2020 16:49
1)
var s:string; i:integer;
begin
write('Слово: ');
readln(s);
for i:=1 to length(s) do
writeln(' ':i,s[i]);
end.
Пример:
Слово: лесенка
л
е
с
е
н
к
а
2)
var s:string; n,i:integer;
begin
write('Слово: ');
readln(s);
write('n = ');
readln(n);
for i:=0 to n-1 do
writeln('':i*length(s),s);
end.
Пример:
Слово: лесенка
n = 4
лесенка
лесенка
лесенка
лесенка
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота