ЗнанияПом1234
24.05.2020 10:36

Написать программу в паскале, которая находит максимальное нечетное отрицательное число среди чисел ,уже записанных в готовом текстовом файле, и выводит результат в другой файл.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Bake2017
05.10.2020 16:38
Program n1;
var a,max: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
max:=0;
while not eof(f) do
begin
read(f,a);
if (abs(a)>max) and (a<0) and (a mod 2 <>0) then max:=a;
end;
close(f);
assign(f,'output.txt');
rewrite(f);
write(f,max);
close(f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота