Ania151
20.01.2023 18:31

Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). размер массива заранее неизвестен. исходные данные записаны в файл input.txt , отсортированный массив нужно вывести в файл output.txt . входные данные первая строка входного файла input.txt содержит размер массива. во второй строке записаны все элементы массива, разделённые пробелами. выходные данные программа должна вывести в файл output.txt все элементы отсортированного массива в одной строке, разделив их пробелами. примеры входные данные 5 5 1 4 2 3 выходные данные 1 2 3 4 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zaxar3512
31.08.2020 20:58
Program n1;
type z = array of integer;
var a: z;
i,n,x,j,buf: integer;
f: text;
begin
randomize;
assign(f,'input.txt');
reset(f);
n:=0;
readln(f,x);
setlength(a,x);
while not eof(f) do
begin
read(f,a[n]);
n:=n+1;
end;
close(f);
for i:=0 to n-2 do
for j:=i+1 to n-1 do
if a[i]>a[j] then begin
buf:=a[i];
a[i]:=a[j];
a[j]:=buf;
end;
assign(f,'output.txt');
rewrite(f);
for i:=0 to x-1 do write(f,a[i],' ');
close(f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота