tazab705
28.09.2021 06:05

Напишите программу,выводящую на экран все отрицательные числа из диапазона (m; n)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vyzgavalja1956
14.08.2020 19:22
Var m,n,k,i:integer;
begin
write('m, n: ');
readln(m,n);
if n<m then begin k:=m; m:=n; n:=k; end;
if m>=0
 then writeln('В диапазоне [',m,',',n,'] нет отрицательных чисел')
 else if n>0 then for i:=m to -1 do write(i,' ')
             else for i:=m to n do write(i,' ');
end.

Пример:
m, n: -5 2
-5 -4 -3 -2 -1 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота