AsdZaKAsd
20.08.2020 13:51

Напишите программу на c++, которая вычисляет значение выражения: y=1+2^2+3^3++n^n (n вводится пользователем)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
стас482
05.10.2020 16:03
//MV C++ 2010
#include <iostream>
#include <cmath>
using namespace std;

long double forpow(int n)
{
double i;
long double rez=0;
  for (i=1; i<=n; i++) rez+=pow(i, i);
return rez;
}

int main()
{
  int a;
  cin >>a;
  cout<<forpow(a);
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота