askatovvv
27.05.2021 16:02

Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с клавиатуры) и вывести на экран сообщение.и определить заканчивается эта сумма на 3,является ли эта сумма четным

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hellppp1
05.10.2020 15:06
//PascalABC.Net 3.2
begin
var x:=readinteger ('Введите x: ');
var sum:=0;
repeat
sum+=x mod 10;
x:=x div 10;
until x=0;
writeln ('Сумма цифр: ', sum);
writeln ('Сумма заканчивается на 3: ', (sum mod 10)=3);
writeln ('Сумма четная - ', sum.Iseven);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота