bur5645
18.06.2021 04:21

На c++ необходимо написать программу, которая вычислит сумму 2/3+3/4+4/5++n−1n. формат входных данных вводится натуральное число n (3≤n≤105). формат выходных данных программа должна вывести результат вычисления одним вещественным числом с точностью до шести знаков после запятой.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
69699696
02.08.2020 21:29
#include <iostream>
using namespace std;

int main()
{
    int n;
    double s=0;
    cout << "n = ", cin >> n, cout << "\n";
    for (int i=2; i<n; i++) {
    s += (double)i/(i+1);
    }
    cout.setf(ios::fixed);
    cout.precision(6);
    cout << "s = " << s << "\n";
    return 0;
}

Пример:
n = 10
s = 6.571032
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота