Татьяна4222
30.08.2022 21:13

Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. входные данные на вход программы подаётся символьная строка. выходные данные программа должна вывести количество различных символов в этой строке. примеры входные данные ab122ab выходные данные 5 pascal abc 1.8

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilhamamanov197
05.10.2020 14:33
Var used: Set of Char;
    s: string;
    i, cnt: integer;
    c: char;
begin
used := [];
readln(s);

for i := 1 to length(s) do
  include(used, s[i]);

cnt := 0;
for c := #0 to #255 do
  if (c in used) then
    cnt := cnt + 1;

writeln(cnt);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота