KOTOMAKS06
07.04.2020 06:12

Напишите программу(pascal) найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Корни
20.08.2020 14:12
Program n1;
var sum,a,c: integer;
begin
readln(a);
sum:=0;
while true do
begin
readln(c);
if c=0 then break;
if c mod a=0 then sum:=sum+c;
end;
writeln(sum);
end.
0,0(0 оценок)
Ответ:
Julia8546
20.08.2020 14:12
Предполагается, что ввод завершает число 0

// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadInteger('a=');
  Writeln(ReadSeqIntegerWhile(x->x<>0).Where(x->x mod a=0).Sum)
end.

Пример
a= 2
5 7 12 8 -4 3 11 0
16
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота