natalibezugla2
02.05.2021 08:36

Написать программу в pascal, которая вычисляет среднюю оценку за неделю (с массивов)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
LadyDay
05.10.2020 14:06
//PascalABC.Net
begin
var a: array of integer;
setLength (a, readinteger('Введите кол-во учеников: '));
for var i:=0 to length(a)-1 do a[i]:=readinteger ('Введите оценку ученика: ');
write ('Средняя оценка: ', a.Average);
end.
0,0(0 оценок)
Ответ:
Tara8808
05.10.2020 14:06
Program n1;
const n=12;
var a: array[1..n] of integer;
i,sum: integer;
begin
randomize;
sum:=0;
write('оценки за неделю: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
end;
writeln;
for i:=1 to n do sum:=sum+a[i];
writeln('среднее арифмитическое: ',sum/n);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота