vikaSnal87
26.01.2021 04:25

Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном расстоянии l на высоте h над уровнем горизонта при заданном угле d и начальной скорости v0.в ответе должен высчитаться угол и написать программа "попал" ты или нет

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Clem404
05.10.2020 13:31

Чтобы наш снаряд (пуля, мяч или что-то еще) попало в цель, нужно чтобы высота подъема снаряда совпала с высотой, на которой расположена цель, и чтобы дальность полета совпала с заданным расстоянием. Иначе снаряд может улететь выше или ниже цели или не долетать.

Воспользуемся формулами по равнозамедленному движению.


program zadacha;

const

g=9.8;

var

h,L,a,V,S,h1:real;

begin

writeln('vvedite visotu i dalnost celi');

readln(h,L);

writeln('vvedite ugol, skorost snariada');

readln(a,V);

a:=a*pi/180;

h1:=int(( sqr(V)* sqr(sin(a))) / (2*g));

S:=int((sqr(V)*sin(2*a))/g);

if (S=L) and (h1=h) then writeln('popal') else writeln('ne popal');

end.


Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном р
Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном р
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота