murrtinez
25.07.2020 11:36

Напишите программу, в которой пользователь вводит 5-тизначное число, а программа выводит 5-тизначное число-перевертыш. на языке пасхаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Adelina12005
05.10.2020 13:27
Var a,a1,a2,a3,a4,a5,b:integer;
begin
write('a = ');
readln(a);
a1:=a div 10000;
a2:=a div 1000 mod 10;
a3:=a div 100 mod 10;
a4:=a mod 100 div 10;
a5:=a mod 10;
b:=a5*10000+a4*1000+a3*100+a2*10+a1;
writeln('b = ',b);
end.

Пример:
a = 13524
b = 42531
0,0(0 оценок)
Ответ:
Dymai11
05.10.2020 13:27
Так как язык программироваия ты не написал, дам ответ на Си++, в данном примере от чистого Си отличается только вводом выводом (cin,cout-scanf,printf)
Решение:
#include "stdafx.h"
#include <iostream>
using namespase std;
int main()
{
setlocale(0,"");
int A[5];
cout<<"Введите пятизначное число, разделяя каждую цифру пробелом"<<endl;
for(int i=0;i<5;i++)
{
cin>>A[i];
}
cout<<"Перевёрнутое число:"<<endl;
for(int i=4;i>=0;i--)
{
cout<<A[i];
}
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота