Kateriна
13.01.2022 22:54

Написать программу, которая проверяет, является ли четным введенное пользователем целое трехзначное число число.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
manoco
05.10.2020 13:29
Условие: Написать программу, которая проверяет, является ли четным введенное пользователем целое трехзначное число.

Путь решения: сохраняем в переменную введенное пользователем число, например в a получаем остаток деления на 2 и сравнимаем с 0. Если равен, то число - четное иначе не четное.
P.S. Так как число a используется в программе меньше или равно 1 раз, то это число можно не сохранять, а сразу работать с ним, в месте вызова функции.

Используемые языки: Pacal, Python, JavaScript

Язык: Pascal
//fpc 3.0.0
Var
    a:integer;
Begin
    read(a);
    if (a mod 2 = 0) then write('Введенное число четное')
    else write('Введенное число нечетное');
End.

ИЛИ
//PascalABC.NET (версия 3.2, сборка 1363)
Begin
  print(ReadInteger() mod 2 = 0 ? 'Введенное число четное' : 'Введенное число нечетное')
End.
Язык: Python
print('Введенное число ' + ('нечетное', 'четное')[int(input()) % 2 == 0])

Язык: JavaScript
alert('Введенное число ' + (Number(prompt()) % 2 === 0 ? 'четное': 'нечетное'));
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота