1) написать программу в паскале, "проверить, являются ли цифры введенного трехзначного числа возрастающей последовательностью" 2) написать программу в паскале, "по введенным координатам точки (х,у) определить в какую четверть попадает эта точка"
1) Program n1; var n:integer; begin write('Введите 3-х значное число: '); readln(n); if ((n div 100 < n div 10 mod 10) and (n div 10 mod 10 < n mod 10)) then writeln('true') else writeln('false'); end. 2) Program n2; var x,y: real; begin readln(x,y); if(x=0) and (y=0) then writeln('точка в начале координат') else if(x>0)and(y>0) then writeln('I четверть') else if(x<0)and(y>0) then writeln('II четверть') else if(x<0)and(y<0) then writeln('III четверть') else if(x>0)and(y<0) then writeln('IV четверть') else if(x=0)and(y<>0) then writeln('точка на оси OY') else if(x<>0)and(y=0) then writeln('точка на оси OX'); end.
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017 // Внимание! Если программа не работает, обновите версию!
№1 begin var s:=ReadInteger.ToString; if s=s.Distinct.Sorted.JoinIntoString('') then Writeln('Цифры являются возрастающей последовательностью') else Writeln('Цифры не являются возрастающей последовательностью') end.
Примеры 148 Цифры являются возрастающей последовательностью
355 Цифры не являются возрастающей последовательностью
№2 begin var x,y:real; Write('Введите координаты точки: '); Read(x,y); if x*y=0 then Writeln('Нули вводить не допускается') else if x*y>0 then if x>0 then Writeln('I четверть') else Writeln('III четверть') else if x>0 then Writeln('IV четверть') else Writeln('II четверть') end.
Пример Введите координаты точки: -2 -3.2 III четверть
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку