oksanaidima
22.12.2021 05:15

Написать программу, которая находит и выводит на печать все четырехзначные числа типа abcd, числа a, b, c, d - различные цифры, для которых выполняется: ab-cd=a+b+c+d на !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dangerrr
05.10.2020 12:15
for a in range(1,10):
    for b in range(0,10):
        for c in range(0,10):
            for d in range(0,10):
                if(a != b and b != c and c != d and a != c and b != d & a != d):
                    if(a * b - c * d == a + b + c + d):
                        print(str(a) + str(b) + str(c) + str(d));
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота