arturshubin24
03.06.2023 01:36

1. даны два ненулевых числа а и b. напишите программу для нахождения суммы, разности, произведения и частного. 2. напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3. ввести трехзначное число a. напишите программу которая поменяет крайние цифры числа местами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kolibri98
05.10.2020 12:10
1)
Program n1;
var a,b: real;
begin
readln(a,b);
writeln('разность: ',a-b);
writeln('произведение: ',a*b);
writeln('сумма: ',a+b);
writeln('частное: ',a/b);
end.
2)
Program n2;
var a,b,c: real;
begin
readln(a,b);
c:=sqrt(a*a+b*b);
writeln('площадь: ',0.5*a*b);
writeln('периметр: ',a+b+c);
end.
3)
Program n3;
var d1,d2,d3,a: integer;
begin
write('введите число: ');
readln(a);
d1:= a div 100;
d2:=a div 10 mod 10;
d3:=a mod 10;
writeln(d3,d2,d1);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота