MaGaFaYa
17.12.2020 01:31

Составить программу.заранее ! дано натуральное число n.найти произведение нечетных цифр числа. верно ли, что произведение числа является трехзначным числом.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
heh18
23.05.2020 23:24

program msd;
uses crt;
var a,l,proiz,b,i:LONGINT;
begin
clrscr;
readln(a);
proiz:=1;
while true do
begin
l:=a mod 10;
a:= a div 10;
if odd(l) = true then
proiz:=proiz*l
else
b:=b+1;
i:=i+1;
if a = 0 then break;
end;
if b = i then writeln('0')
else
writeln(proiz);
if (proiz>99) and (proiz<1000) then writeln('Da')
else writeln('Net');
ReADKeY;
eND.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота