Vika201880
06.11.2020 11:29

50 ! напишите программу. в первой строке вводится натуральное чило n вывести на экран - произведение нечетных цифр числа (считается, что хотя бы одна нечетная цифра в числе имеется) на c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
maruad1
26.08.2020 08:17
#include <iostream>
using namespace std;

int main() { 
   int n,k=1,m,p=0;
   cout<<"n = ";  cin>>n;
   while (n>0) {
     m=n%10;
     if (m%2==1) { k*=m; p=1; }
     n=n/10;
   }
   if (p>0) cout<<"result: "<<k;
   else cout<<"no odd digits";
   cout<<endl;

   system("pause");
   return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота