аличка77
20.08.2022 00:55

Написать программу для паскаль abc, которая меняет в массиве наибольшее и наименьшее число. например, исходные числа: 5 6 1 2 7 программа меняет на: 5 6 7 2 1

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Den2891
05.10.2020 11:16
Program n1;
const n = 6;
var a : array[1..n] of integer;
i, max, min, temp : integer;
begin
for i := 1 to n do readln(a[i]);
min := 1;
max := 1;
for i := 1 to n do
begin
if a[i] > a[max] then max := i;
if a[i] < a[min] then min := i;
end;
temp := a[max];
a[max] := a[min];
a[min] := temp;
for i := 1 to n do write(a[i],' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота