nazardovhanich
07.06.2022 12:08

Составьте программу, которая определяет число разрядов заданного натурального числа n (подсказка: сколько раз должна выполняться n=n div 10, чтобы получилось n=0)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lokator505
24.04.2020 14:55
Program n1;
var c: longint;
function ch(n: longint ): longint;
var i: longint;
begin
i := 0;
while n > 0 do
begin
n := n div 10;
i := i + 1
end;
ch:= i
end;
begin
write ('Введите число: ');
readln (c);
if c<0 then c:=abs(c);
writeln ('в этом числе ',ch(c),' разрядов ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота