monsterhi003
18.09.2020 15:01

Напишите программу, которая заполняет массив квадратами натуральных чисел от 1 до n . входные данные входная строка содержит размер массива n . гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести содержимое массива: квадраты n первых натуральных чисел. пример входных данных 5 результат работы программы 1 4 9 16 25 пример входных данных 2 результат работы программы 1 4 с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Эliна
05.10.2020 10:04
#include <iostream>
using namespace std;
int main()
{
int n;
cout<<"enter n: "<<endl;
cin>>n;
if (n>0 && n<=10000)
{
int a[n];
int c=1;
a[0]=1;
for(int i=1;i<n;i++)
{
c=c+1;
a[i]=c*c;
}
for(int i=0; i<n ;i++ )
{
cout<<a[i]<<" ";
}
}
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота